const regex = /\s{2,}|\(R\)|\(TM\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s{2,}|\\(R\\)|\\(TM\\)', 'gm')
const str = `Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);