$re = '/\s{2,}|\(R\)|\(TM\)/m';
$str = 'Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;