using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s{2,}|\(R\)|\(TM\)";
string substitution = @" ";
string input = @"Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}