use strict;
my $str = 'Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz';
my $regex = qr/\s{2,}|\(R\)|\(TM\)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";