package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s{2,}|\(R\)|\(TM\)`)
var str = `Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}