re = /\s{2,}|\(R\)|\(TM\)/m
str = 'Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result