# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s{2,}|\(R\)|\(TM\)/ /gm;t' <<< "Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz"