#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s{2,}|\(R\)|\(TM\)"
Local $sString = "Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)