import Foundation
let pattern = #""([0-9]+)px""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"320px"
400
"rgb(255, 0, 0)"
"2px"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)