const regex = /"([0-9]+)px"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([0-9]+)px"', 'g')
const str = `"320px"
400
"rgb(255, 0, 0)"
"2px"`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);