$re = '/"([0-9]+)px"/';
$str = '"320px"
400
"rgb(255, 0, 0)"
"2px"';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;