re = /"([0-9]+)px"/
str = '"320px"
400
"rgb(255, 0, 0)"
"2px"'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result