// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""([0-9]+)px""#).unwrap();
let string = "\"320px\"
400
\"rgb(255, 0, 0)\"
\"2px\"";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}