#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""([0-9]+)px""
Local $sString = ""320px"" & @CRLF & _
"400" & @CRLF & _
""rgb(255, 0, 0)"" & @CRLF & _
""2px""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)