use strict;
my $str = '"320px"
400
"rgb(255, 0, 0)"
"2px"';
my $regex = qr/"([0-9]+)px"/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";