# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"([0-9]+)px"/$1/g;t' <<< "\"320px\"
400
\"rgb(255, 0, 0)\"
\"2px\""