import Foundation
let pattern = #"(?<a>.*)(?<b>[0-9]\.[0-9]*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
*Material, name=Porosity_Hardin_Beckermann
*Elastic, dependencies=1
210000.000000000, 0.300000000, 0.000000000
189625.778743714, 0.293220339, 0.020000000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${a}, ${b}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)