package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<a>.*)(?<b>[0-9]\.[0-9]*$)`)
var str = `*Material, name=Porosity_Hardin_Beckermann
*Elastic, dependencies=1
210000.000000000, 0.300000000, 0.000000000
189625.778743714, 0.293220339, 0.020000000`
var substitution = "${a}, ${b}"
fmt.Println(re.ReplaceAllString(str, substitution))
}