using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<a>.*)(?<b>[0-9]\.[0-9]*$)";
string substitution = @"${a}, ${b}";
string input = @"*Material, name=Porosity_Hardin_Beckermann
*Elastic, dependencies=1
210000.000000000, 0.300000000, 0.000000000
189625.778743714, 0.293220339, 0.020000000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}