$re = '/(?<a>.*)(?<b>[0-9]\.[0-9]*$)/m';
$str = '*Material, name=Porosity_Hardin_Beckermann
*Elastic, dependencies=1
210000.000000000, 0.300000000, 0.000000000
189625.778743714, 0.293220339, 0.020000000';
$subst = "${a}, ${b}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;