const regex = /(?<a>.*)(?<b>[0-9]\.[0-9]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<a>.*)(?<b>[0-9]\\.[0-9]*$)', 'gm')
const str = `*Material, name=Porosity_Hardin_Beckermann
*Elastic, dependencies=1
210000.000000000, 0.300000000, 0.000000000
189625.778743714, 0.293220339, 0.020000000`;
const subst = `${a}, ${b}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);