import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<a>.*)(?<b>[0-9]\\.[0-9]*$)";
final String string = "*Material, name=Porosity_Hardin_Beckermann\n"
+ "*Elastic, dependencies=1\n"
+ "210000.000000000, 0.300000000, 0.000000000\n"
+ "189625.778743714, 0.293220339, 0.020000000";
final String subst = "${a}, ${b}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}