use strict;
my $str = '*Material, name=Porosity_Hardin_Beckermann
*Elastic, dependencies=1
210000.000000000, 0.300000000, 0.000000000
189625.778743714, 0.293220339, 0.020000000';
my $regex = qr/(?<a>.*)(?<b>[0-9]\.[0-9]*$)/mp;
my $subst = '${a}, ${b}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";