# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<a>.*)(?<b>[0-9]\.[0-9]*$)"
test_str = ("*Material, name=Porosity_Hardin_Beckermann\n"
"*Elastic, dependencies=1\n"
"210000.000000000, 0.300000000, 0.000000000\n"
"189625.778743714, 0.293220339, 0.020000000")
subst = "${a}, ${b}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.