# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<a>.*)(?<b>[0-9]\.[0-9]*$)/${a}, ${b}/gm;t' <<< "*Material, name=Porosity_Hardin_Beckermann
*Elastic, dependencies=1
210000.000000000, 0.300000000, 0.000000000
189625.778743714, 0.293220339, 0.020000000"