// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<a>.*)(?<b>[0-9]\.[0-9]*$)").unwrap();
let string = "*Material, name=Porosity_Hardin_Beckermann
*Elastic, dependencies=1
210000.000000000, 0.300000000, 0.000000000
189625.778743714, 0.293220339, 0.020000000";
let substitution = "${a}, ${b}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}