import Foundation
let pattern = #"^(\d+(?:\.\d{1,3})?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
23.554656561568181681916651651615618
42.8865465465
468
40.541222
0
50
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1%"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)