// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+(?:\.\d{1,3})?)").unwrap();
let string = "23.554656561568181681916651651615618
42.8865465465
468
40.541222
0
50";
let substitution = "$1%";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}