package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+(?:\.\d{1,3})?)`)
var str = `23.554656561568181681916651651615618
42.8865465465
468
40.541222
0
50`
var substitution = "$1%"
fmt.Println(re.ReplaceAllString(str, substitution))
}