const regex = new RegExp('^(\\d+(?:\\.\\d{1,3})?)', 'gm')
const str = `23.554656561568181681916651651615618
42.8865465465
468
40.541222
0
50`;
const subst = `$1%`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);