use strict;
my $str = '23.554656561568181681916651651615618
42.8865465465
468
40.541222
0
50';
my $regex = qr`^(\d+(?:\.\d{1,3})?)`mp;
my $subst = '$1%';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";