#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d+(?:\.\d{1,3})?)"
Local $sString = "23.554656561568181681916651651615618" & @CRLF & _
"" & @CRLF & _
"42.8865465465" & @CRLF & _
"468" & @CRLF & _
"" & @CRLF & _
"40.541222" & @CRLF & _
"" & @CRLF & _
"0" & @CRLF & _
"" & @CRLF & _
"50"
Local $sSubst = "$1%"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)