re = /^(\d+(?:\.\d{1,3})?)/m
str = '23.554656561568181681916651651615618
42.8865465465
468
40.541222
0
50'
subst = '$1%'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result