using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+(?:\.\d{1,3})?)";
string substitution = @"$1%";
string input = @"23.554656561568181681916651651615618
42.8865465465
468
40.541222
0
50";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}