import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+(?:\\.\\d{1,3})?)";
final String string = "23.554656561568181681916651651615618\n\n"
+ "42.8865465465\n"
+ "468\n\n"
+ "40.541222\n\n"
+ "0\n\n"
+ "50";
final String subst = "$1%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}