# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+(?:\.\d{1,3})?)/$1%/gm;t' <<< "23.554656561568181681916651651615618
42.8865465465
468
40.541222
0
50"