// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)((?:w|W)ells (?:M|m)ail(?:B|b)ox (?:Managment|Management|managment|management) (?:C|c)enter)").unwrap();
let string = "
Wells managment has shared a mandetory file with you
Wells MailBox Managment Center
wells mailbox management center
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}