using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:w|W)ells (?:M|m)ail(?:B|b)ox (?:Managment|Management|managment|management) (?:C|c)enter)";
string substitution = @"";
string input = @"
Wells managment has shared a mandetory file with you
Wells MailBox Managment Center
wells mailbox management center
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}