# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:w|W)ells (?:M|m)ail(?:B|b)ox (?:Managment|Management|managment|management) (?:C|c)enter)//igm;t' <<< "
Wells managment has shared a mandetory file with you
Wells MailBox Managment Center
wells mailbox management center
"