use strict;
my $str = '
Wells managment has shared a mandetory file with you
Wells MailBox Managment Center
wells mailbox management center
';
my $regex = qr/((?:w|W)ells (?:M|m)ail(?:B|b)ox (?:Managment|Management|managment|management) (?:C|c)enter)/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";