# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:w|W)ells (?:M|m)ail(?:B|b)ox (?:Managment|Management|managment|management) (?:C|c)enter)"
test_str = ("\n"
"Wells managment has shared a mandetory file with you\n\n\n"
"Wells MailBox Managment Center\n"
"wells mailbox management center\n\n\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.