$re = '/((?:w|W)ells (?:M|m)ail(?:B|b)ox (?:Managment|Management|managment|management) (?:C|c)enter)/im';
$str = '
Wells managment has shared a mandetory file with you
Wells MailBox Managment Center
wells mailbox management center
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;