import Foundation
let pattern = #"(?<a>[^\ \ ]*)(?:\()(?<b>[^\)]*)(?:\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"5 * 6 + set(asdsa.sadassa.$asdsadsa) + 5 + avg(asdsad) + 5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"SUM"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)