// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<a>[^\ \ ]*)(?:\()(?<b>[^\)]*)(?:\))").unwrap();
let string = "5 * 6 + set(asdsa.sadassa.$asdsadsa) + 5 + avg(asdsad) + 5";
let substitution = "SUM";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}