#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<a>[^\ \ ]*)(?:\()(?<b>[^\)]*)(?:\))"
Local $sString = "5 * 6 + set(asdsa.sadassa.$asdsadsa) + 5 + avg(asdsad) + 5"
Local $sSubst = "SUM"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)