const regex = /(?<a>[^\ \ ]*)(?:\()(?<b>[^\)]*)(?:\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<a>[^\\ \\ ]*)(?:\\()(?<b>[^\\)]*)(?:\\))', 'gm')
const str = `5 * 6 + set(asdsa.sadassa.\$asdsadsa) + 5 + avg(asdsad) + 5`;
const subst = `SUM`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);