package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<a>[^\ \ ]*)(?:\()(?<b>[^\)]*)(?:\))`)
var str = `5 * 6 + set(asdsa.sadassa.$asdsadsa) + 5 + avg(asdsad) + 5`
var substitution = "SUM"
fmt.Println(re.ReplaceAllString(str, substitution))
}