$re = '/(?<a>[^\ \ ]*)(?:\()(?<b>[^\)]*)(?:\))/m';
$str = '5 * 6 + set(asdsa.sadassa.$asdsadsa) + 5 + avg(asdsad) + 5';
$subst = "SUM";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;