re = /(?<a>[^\ \ ]*)(?:\()(?<b>[^\)]*)(?:\))/m
str = '5 * 6 + set(asdsa.sadassa.$asdsadsa) + 5 + avg(asdsad) + 5'
subst = 'SUM'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result