import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<a>[^\\ \\ ]*)(?:\\()(?<b>[^\\)]*)(?:\\))";
final String string = "5 * 6 + set(asdsa.sadassa.$asdsadsa) + 5 + avg(asdsad) + 5";
final String subst = "SUM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}